Quantcast
Channel: RV3 » UNIX
Viewing all articles
Browse latest Browse all 5

ISO to USB

$
0
0
  1. Get ISO file
  2. Open Terminal /Applications/Utilities/Terminal.app
  3. Convert the .iso file to .img
    hdiutil convert -format UDRW -o ~/path/to/target.img ~/path/to/source.iso
    Note: OS X tends to put the .dmg ending on the output file automatically.
  4. Insert USB stick
  5. Run diskutil list  and determine the device node assigned to your flash media (e.g. /dev/disk2)
  6. Run diskutil unmountDisk /dev/diskN
    replace N with the disk number from the last command; in the previous example, N would be 2
  7. Run sudo dd if=/path/to/target.img of=/dev/rdiskN bs=1m
    replace /path/to/target.img with the path where the converted image file is located; for example, /Users/me/path/to/target.img
    replace /de/rdiskN with your media number; for example: /dev/rdisk2
    • Using /dev/rdisk instead of /dev/disk may be faster
    • If you see the error dd: Invalid number ’1m’, you are using GNU dd. Use the same command but replace bs=1m with bs=1M
    • If you see the error dd: /dev/diskN: Resource busy, make sure the disk is not in use. Start the ‘Disk Utility.app’ and unmount (don’t eject) the drive
  8. Run diskutil eject /dev/diskN and remove your flash media when the command completes.
  9. Ready to deploy:)

Viewing all articles
Browse latest Browse all 5

Latest Images

Trending Articles





Latest Images